ElmerPost compilation fails...

Post processing utility for Elmer
Post Reply
Alexvader
Posts: 5
Joined: 18 Jan 2010, 20:12

ElmerPost compilation fails...

Post by Alexvader » 21 Jan 2010, 03:26

Hi Forum,

I have installed elmer to

/usr/local/elmer-5.4.1

so libmatc.a libes in /usr/local/elmer-5.4.1/lib :

Code: Select all

alex@iskandhar:~/trunk/post$ ls -l /usr/local/elmer-5.4.1/lib
total 19352
-rw-r--r-- 1 root root  203736 2010-01-20 23:23 libamd.a
-rw-r--r-- 1 root root   51574 2010-01-20 23:23 libamdf77.a
-rw-r--r-- 1 root root  653610 2010-01-20 23:23 libarpack.a
-rw-r--r-- 1 root root  604064 2010-01-20 23:23 libblas.a
-rw-r--r-- 1 root root  153596 2010-01-20 23:23 libeioc.a
-rw-r--r-- 1 root root  153770 2010-01-20 23:23 libeiof.a
-rwxr-xr-x 1 root root 4074387 2010-01-20 23:23 libelmersolver.so
-rw-r--r-- 1 root root  596430 2010-01-20 23:23 libhuti.a
-rw-r--r-- 1 root root 7917140 2010-01-20 23:23 liblapack.a
-rw-r--r-- 1 root root  236132 2010-01-20 23:23 libmatc.a
-rw-r--r-- 1 root root 5093668 2010-01-20 23:23 libumfpack.a
alex@iskandhar:~/trunk/post$

yet when I try to compile ElmerPost, i get this error... :

Code: Select all

total 716
drwxr-xr-x  7 alex users   4096 2010-01-21 00:14 .
drwxr-xr-x 19 alex users   4096 2010-01-20 23:22 ..
drwxr-xr-x  6 alex users   4096 2010-01-20 23:05 .svn
-rwxrwxrwx  1 alex users     12 2010-01-20 22:57 Makefile.am
-rw-r--r--  1 alex users  20131 2010-01-21 00:13 Makefile.in
-rwxrwxrwx  1 alex users     39 2010-01-20 22:57 README
-rw-r--r--  1 alex users  33235 2010-01-21 00:13 aclocal.m4
-rwxrwxrwx  1 alex users  40488 2010-01-20 22:57 acx_elmer.m4
-rwxrwxrwx  1 alex users   2657 2010-01-20 22:57 acx_ftgl.m4
-rwxrwxrwx  1 alex users  11469 2010-01-20 22:57 acx_gl.m4
-rwxrwxrwx  1 alex users    221 2010-01-20 22:57 autogen.sh
drwxrwxrwx  3 alex users   4096 2010-01-21 00:13 autom4te.cache
-rwxrwxrwx  1 alex users   4955 2010-01-20 22:57 autoscan.log
-rwxr-xr-x  1 alex users  44878 2010-01-21 00:13 config.guess
-rwxrwxrwx  1 alex users   6170 2010-01-20 22:57 config.h.in
-rwxrwxrwx  1 root root   37863 2010-01-21 00:14 config.log
-rwxr-xr-x  1 alex users  33387 2010-01-21 00:13 config.sub
-rwxrwxrwx  1 alex users 374211 2010-01-21 00:13 configure
-rwxrwxrwx  1 alex users   3113 2010-01-20 22:57 configure.in
-rwxrwxrwx  1 alex users   1108 2010-01-20 22:57 configure.scan
drwxrwxrwx  3 alex users   4096 2010-01-20 22:57 data
-rwxr-xr-x  1 alex users  17867 2010-01-21 00:13 depcomp
drwxrwxrwx  6 alex users   4096 2010-01-20 22:57 doc
-rwxr-xr-x  1 alex users  13620 2010-01-21 00:13 install-sh
-rwxr-xr-x  1 alex users  11135 2010-01-21 00:13 missing
drwxrwxrwx 19 alex users   4096 2010-01-21 00:13 src
alex@iskandhar:~/trunk/post$ ./configure

------------------------------------------------------------------

checking for 64 bit FFLAGS... -m64 -fPIC
checking size of void*... 8
checking to see if we got 64 bits... oh yes
checking how to get verbose linking output from gfortran... -v
checking for Fortran libraries of gfortran...  -L/usr/lib64/gcc/x86_64-slackware-linux/4.3.3 -L/usr/lib64/gcc/x86_64-slackware-linux/4.3.3/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/opt/intel/mkl/10.2.2.025/lib/em64t -L/opt/intel/Compiler/11.1/059/lib/intel64 -L/usr/lib64/gcc/x86_64-slackware-linux/4.3.3/../../../../x86_64-slackware-linux/lib -L/usr/lib64/gcc/x86_64-slackware-linux/4.3.3/../../.. -lgfortranbegin -lgfortran -lm
checking for dummy main to link with Fortran libraries... none
checking for Fortran name-mangling scheme... lower case, underscore, no extra underscore
checking whether we are using the Microsoft C compiler... no
checking for Fortran char* mangling scheme... char_ptr
checking for mtc_init in -lmatc... no
configure: error: Couldn't link to MATC, make sure that libmatc is available and it works with your compiler.
alex@iskandhar:~/trunk/post$


compiling with

Code: Select all

alex@iskandhar:~/trunk/post$ ./configure --with-matc=/usr/local/elmer-5.4.1/lib/libmatc.a

---------------------------------------------------------------


lib/../lib64 -L/opt/intel/mkl/10.2.2.025/lib/em64t -L/opt/intel/Compiler/11.1/059/lib/intel64 -L/usr/lib64/gcc/x86_64-slackware-linux/4.3.3/../../../../x86_64-slackware-linux/lib -L/usr/lib64/gcc/x86_64-slackware-linux/4.3.3/../../.. -lgfortranbegin -lgfortran -lm
checking for dummy main to link with Fortran libraries... none
checking for Fortran name-mangling scheme... lower case, underscore, no extra underscore
checking whether we are using the Microsoft C compiler... no
checking for Fortran char* mangling scheme... char_ptr
checking for mtc_init in /usr/local/elmer-5.4.1/lib/libmatc.a... no
checking for mtc_init in -lmatc... no
configure: error: Couldn't link to MATC, make sure that libmatc is available and it works with your compiler.
alex@iskandhar:~/trunk/post$


What can I do more to compile post....?


BRGDS

Alex


I have used the following Install script

Code: Select all

alex@iskandhar:~/trunk$ cat buildscript
#!/bin/sh -f
# Compile Elmer modules and install it
#

# replace these with your compilers:
export CC=gcc
export CXX=g++
export FC=gfortran
export F77=gfortran

modules="matc umfpack mathlibs elmergrid meshgen2d eio hutiter fem"
for m in $modules; do
  cd $m
  ./configure --prefix=/usr/local/elmer-5.4.1
  make
  make install
  cd ..
done
alex@iskandhar:~/trunk$

Post Reply