New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

The graphical user interface of Elmer
Post Reply
ender_wiggin
Posts: 18
Joined: 21 Jun 2023, 22:56
Antispam: Yes

New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

Post by ender_wiggin »

Very simply, I downloaded the ElmerGUI with MPI binary that was last compiled on December 14, 2023. Using the default parallel solver options the simulation fails to proceed because of a segmentation fault. I have zero clue as to what I am looking at. My sif file and the simulation log file are attached.
Attachments
failed_parallel.log
(2.94 KiB) Downloaded 17 times
case.sif
(2.34 KiB) Downloaded 14 times
kevinarden
Posts: 2286
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

Post by kevinarden »

Do you need parallel? Serial is much easier.
Did you follow these instructions?
http://www.nic.funet.fi/pub/sci/physics ... dElmer.pdf
How many processors are the default parallel solver set to?
Do you have that many processors?

I would start with serial until you get familiar with the code.
http://www.nic.funet.fi/pub/sci/physics ... dElmer.pdf
http://www.nic.funet.fi/pub/sci/physics ... orials.pdf

you can use the MPI solver in serial mode.
ender_wiggin
Posts: 18
Joined: 21 Jun 2023, 22:56
Antispam: Yes

Re: New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

Post by ender_wiggin »

I have already run the said problem in serial mode as well as running in serial mode with the MPI solver provided you are referring to the MPI installation as the MPI solver. I originally installed the non-mpi version which managed to get running. I decided to uninstall and then install the MPI version because I wanted parallel computing.

I'm trying to run with 4 cores.

I had not followed the Getting Started document, and instead jumped right into an amalgamation of tutorials (document and video format) to achieve the outcome for which I was looking.

I am currently going through the document right now.
kevinarden
Posts: 2286
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

Post by kevinarden »

For some reason the log file says there was no fourth mesh. But lets, let your work through the documentation, and then see if that remains an issue.
ender_wiggin
Posts: 18
Joined: 21 Jun 2023, 22:56
Antispam: Yes

Re: New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

Post by ender_wiggin »

kevinarden wrote: 22 Dec 2023, 20:08 Do you need parallel? Serial is much easier.
Did you follow these instructions?
http://www.nic.funet.fi/pub/sci/physics ... dElmer.pdf
How many processors are the default parallel solver set to?
Do you have that many processors?

I would start with serial until you get familiar with the code.
http://www.nic.funet.fi/pub/sci/physics ... dElmer.pdf
http://www.nic.funet.fi/pub/sci/physics ... orials.pdf

you can use the MPI solver in serial mode.
I believe I have now determined the source of the issue. It was the fact that my file paths for the projects had spaces in the names. What's frustrating is that the point was not made until after it was expected that the first two tests in Chapter 8 (8.1-8.3) do not mention anything about not having them in the path name. It does finally state this in section 8.4, but this is only after success was assumed. I was about to post the fact that the parallel portion of the tutorial failed the same way, but I just so happened to take a gander at the next section and learned the issue. I don't believe that to be what most people would do, and I would include myself in that "most people." I would expect most people to stop and try to solve the problems with that step before moving on.

Maybe there is another location hidden in the many documents that states parallel solvers will not work with spaces in the file paths, but that certainly isn't what I would expect considering that serial solver has no issues with spaces.

Thank you kevinarden.
kevinarden
Posts: 2286
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

Post by kevinarden »

Really old people remember a time when paths, file names, directories, etc. did not support spaces, characters, and were case sensitive, etc. , and out of habit follow those conventions. Modern operating systems do not care anymore, but there may be things buried in older codes, that follow the old ways.
ashishs
Posts: 1
Joined: 16 Jan 2024, 13:23
Antispam: Yes

Re: New Install of ElmerGUI with MPI on Windows - Parallel fails with segmentation fault - invalid memory reference

Post by ashishs »

I am also getting the segmentation fault error, but I don't have any spaces in my directory address. I get the error when reading the partitioned result from a previous steady state solution. The result file is quite large, so I can't post here. From the output log, I suspect that ElmerSolver_mpi is only reading the result.0 file. Can anyone help? Here are the sif and log files:
case_restart.sif
(7.58 KiB) Downloaded 14 times
restart_fail.log
(11.28 KiB) Downloaded 14 times
Update: I've found that changing the restart case from steady state to transient doesn't give the error, as long as 'Fix Input Current Density = False' in the MgDyn solver. I wonder why though. But this means that my previous suspicion about all result file not being read was incorrect.
Post Reply