[SOLVED] ElmerGrid failing to set partitioning on nodes

Mesh generators, CAD programs, and other tools
Post Reply
thomasatelmer
Posts: 38
Joined: 18 Jan 2019, 18:18
Antispam: Yes

[SOLVED] ElmerGrid failing to set partitioning on nodes

Post by thomasatelmer »

Hello, dear fellow Elmer users,
I am currently trying to use Elmer on a multi-body mesh coming from Salome with quadratic elements. I am trying to have ElmerGrid partiion the mesh in multiple partitions, in the attached example 3 partitions. Up to the point that ElmerGrid sets the partition info on the different nodes, all works fine - The mesh has also been autocleaned on the way from Salome to Elmer. In the ElmerGrid output, But on some/most of the nodes, ElmerGrid throws the error "Cannot set partitioning for node XXXXX Invalid partition YYYYYYY for node XXXXX" I do not see any further obvious error messages before that would light the way, so I wonder if one of the readers on this forum has maybe some hint? Somehow it smells like something obvious once you know it, but I am definitely lost...

Characteristic ElmerGrid partitioning action output is attached in the hope that it is helpful. Any further detail surely can be delivered as needed.

Thank you,
Thomas.
Attachments
partitioning_error.txt
(5.04 KiB) Downloaded 50 times
Last edited by thomasatelmer on 30 Mar 2021, 00:19, edited 1 time in total.
raback
Site Admin
Posts: 4173
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: ElmerGrid failing to set partitioning on nodes

Post by raback »

Hi

Haven't seen this before.

Maybe you could try using the dual mesh

Code: Select all

ElmerGrid 2 2 mesh -partdual -metiskway #np
-Peter
thomasatelmer
Posts: 38
Joined: 18 Jan 2019, 18:18
Antispam: Yes

Re: ElmerGrid failing to set partitioning on nodes

Post by thomasatelmer »

Hi Peter,

thank you very much for the quick answer. I tried the setting, and Elmergrid worked without error message. Partitions were written like intended. So in short words - I ordered Elmergrid to use a different partitioning routine, not only based on nodal connections, but also element connections?

Having this cleared now, I have no excuse not to start my calculation by tonight :-) Hope it works,

Thomas.
thomasatelmer
Posts: 38
Joined: 18 Jan 2019, 18:18
Antispam: Yes

Re: ElmerGrid failing to set partitioning on nodes

Post by thomasatelmer »

Hi Peter and interested readers,

succeeding on the partitioning thanks to Peter's input, the calculation is underway for now about 5 hours (a fairly big one). Convergence is good, and so I'd expect everything to run smoothly from hereon, and I'll mark this thread as closed.

Thanks and have a good night,
Thomas.
raback
Site Admin
Posts: 4173
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: [SOLVED] ElmerGrid failing to set partitioning on nodes

Post by raback »

Hi

There could be something needing attention when partitioning higher order elements using the nodal graph. That is how are nodes connected to nodes.

Still, the elemental graph (which is a dual to the nodal graph as the math people say) is more robust here. It will create smoother interfaces and the elemental partitioning is actually the natural one. Each partition assembles its own elements and shares info on the shared nodes when solving the equations. No information is shared during assembly.

-Peter
Post Reply